Centos7编译升级Cmake到最新版本


因为安装Pcap_DNSProxy需要,Centos7自带的cmake 2.8版本太旧需要升级。

所以需要升级Cmake到最新版本

官网下载地址:https://cmake.org/download/


开始安装


下载Cmake最新版本

wget https://cmake.org/files/v3.12/cmake-3.12.3.tar.gz

解压文件

tar zxvf cmake-3.12.3.tar.gz

进入文件夹

cd cmake-3.12.3

编译安装

./bootstrap
make && make install


加入环境变量

export CMAKE_HOME=/usr/local/bin/cmake
export PATH=$PATH:$CMAKE_HOME/bin
source /etc/profile


安装后版本号就变成最新的了

最新回复 (0)
全部楼主
返回
发新帖